Android Plugin is too old, please update to more recent version error

On Updating the Android software like play services,build tools etc… Android studio throws Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE environment variable  error, it is because application requires new version of Gradle to build.

To overcome this error, just open the project Build.Gradle file and update dependencies classpath to the most recent version of gradle. i.e.

dependencies {
classpath 'com.android.tools.build:gradle:1.5.0'
}

Earlier i was using the beta version of gradle & now its updated to the most recent version. Now try syncing the gradle, it takes few minutes to download and the re-build the project.